青海網站建設、網絡推廣最好的公司--您身邊的網站建設專家,馬上拿起電話,聯系我們:0971-8235355   
青海西寧網站建設、網站制作公司-西寧威勢電子信息服務有限公司 首頁 |  公司簡介 |  網站建設 |  網絡推廣 |  空間租用 |  域名注冊 |  企業郵局 |  網絡安全 |  網站編程 |  客服中心 |  聯系我們 |  人才招聘
 
西寧威勢最新網站制做案例展示
Lastest Project
 
西寧網站建設  
當前位置為:首頁 >> 網絡知識 >> 正文  
CISCO技術--Switching 命令大全

文章來源: 西寧威勢電子信息服務有限公司     發布時間:2008-11-28    瀏覽次數:3564    tags:Switching 命令

轉載請注明出處

作者:慕容豪情
出處:http://www.cnsafe.org/
『安全驛站』onLine Security DeFender

1.在基于IOS的交換機上設置主機名/系統名:
switch(config)# hostname hostname
  在基于CLI的交換機上設置主機名/系統名:
switch(enable) set system name name-string

2.在基于IOS的交換機上設置登錄口令:
switch(config)# enable password level 1  password
  在基于CLI的交換機上設置登錄口令:
switch(enable) set password
switch(enable) set enalbepass

3.在基于IOS的交換機上設置遠程訪問:
switch(config)# interface vlan 1
              switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
  在基于CLI的交換機上設置遠程訪問:
switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway

4.在基于IOS的交換機上啟用和瀏覽CDP信息:
switch(config-if)# cdp enable
switch(config-if)# no cdp enable
  為了查看Cisco鄰接設備的CDP通告信息:
switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
  在基于CLI的交換機上啟用和瀏覽CDP信息:
switch(enable) set cdp {enable|disable} module/port
  為了查看Cisco鄰接設備的CDP通告信息:
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

5.基于IOS的交換機的端口描述:
switch(config-if)# description description-string
  基于CLI的交換機的端口描述:
switch(enable)set port name module/number description-string

6.在基于IOS的交換機上設置端口速度:
switch(config-if)# speed{10|100|auto}
  在基于CLI的交換機上設置端口速度:
switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}

7.在基于IOS的交換機上設置以太網的鏈路模式:
switch(config-if)# duplex {auto|full|half}
  在基于CLI的交換機上設置以太網的鏈路模式:
switch(enable) set port duplex module/number {full|half}

8.在基于IOS的交換機上配置靜態VLAN:
switch# vlan database
switch(vlan)# vlan vlan-num name vlan-name
switch(vlan)# exit
switch# configure teriminal
switch(config)# interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
在基于CLI的交換機上配置靜態VLAN:
switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list

9. 在基于IOS的交換機上配置VLAN中繼線:
switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于CLI的交換機上配置VLAN中繼線:
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
          Vlan-range [isl|dotlq|dotl0|lane|negotiate]

10.在基于IOS的交換機上配置VTP管理域:
switch# vlan database
switch(vlan)# vtp domain domain-name
    在基于CLI的交換機上配置VTP管理域:
switch(enable) set vtp [domain domain-name]

11.在基于IOS的交換機上配置VTP 模式:
switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
     在基于CLI的交換機上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

12. 在基于IOS的交換機上配置VTP版本:
switch# vlan database
switch(vlan)# vtp v2-mode
     在基于CLI的交換機上配置VTP版本:
switch(enable) set vtp v2 enable

13. 在基于IOS的交換機上啟動VTP剪裁:
switch# vlan database
switch(vlan)# vtp pruning
    在基于CL I 的交換機上啟動VTP剪裁:
switch(enable) set vtp pruning enable

14.在基于IOS的交換機上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
    在基于CLI的交換機上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

15.在基于IOS的交換機上調整根路徑成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于CLI的交換機上調整根路徑成本:
switch(enable) set spantree portcost moudle/port cost
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

16.在基于IOS的交換機上調整端口ID:
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于CLI的交換機上調整端口ID:
switch(enable) set spantree portpri {mldule/port}priority
switch(enable) set spantree portvlanpri {module/port}priority [vlans]

17. 在基于IOS的交換機上修改STP時鐘:
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
`switch(config)# spanning-tree [vlan vlan-list] max-age seconds
     在基于CLI的交換機上修改STP時鐘:
switch(enable) set spantree hello interval[vlan]
switch(enable) set spantree fwddelay delay [vlan]
switch(enable) set spantree maxage agingtiame[vlan]

18. 在基于IOS的交換機端口上啟用或禁用Port Fast 特征:
switch(config-if)#spanning-tree portfast
     在基于CLI的交換機端口上啟用或禁用Port Fast 特征:
switch(enable) set spantree portfast {module/port}{enable|disable}

19. 在基于IOS的交換機端口上啟用或禁用UplinkFast 特征:
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
     在基于CLI的交換機端口上啟用或禁用UplinkFast 特征:
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

20. 為了將交換機配置成一個集群的命令交換機,首先要給管理接口分配一個IP地址,然后使用下列命令:      switch(config)# cluster enable cluster-name

21. 為了從一條中繼鏈路上刪除VLAN,可使用下列命令:
switch(enable) clear trunk module/port vlan-range

22. 用show vtp domain 顯示管理域的VTP參數.

23. 用show vtp statistics顯示管理域的VTP參數.

24. 在Catalyst交換機上定義TrBRF的命令如下:
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

25. 在Catalyst交換機上定義TrCRF的命令如下:
switch (enable) set vlan vlan-num [name name] type trcrf
         {ring hex-ring-num|decring decimal-ring-num} parent vlan-num

26. 在創建好TrBRF VLAN之后,就可以給它分配交換機端口.對于以太網交換,可以采用如下命令給VLAN分配端口:
switch(enable) set vlan vlan-num mod-num/port-num

27. 命令show spantree顯示一個交換機端口的STP狀態.

28. 配置一個ELAN的LES和BUS,可以使用下列命令:
ATM (config)# interface atm number.subint multioint
ATM(config-subif)# lane serber-bus ethernet elan-name

29. 配置LECS:
ATM(config)# lane database database-name
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
ATM(lane-config-databade)# name …

30. 創建完數據庫后,必須在主接口上啟動LECS.命令如下:
ATM(config)# interface atm number
ATM(config-if)# lane config database database-name
ATM(config-if)# lane config auto-config-atm-address

31. 將每個LEC配置到一個不同的ATM子接口上.命令如下:
ATM(config)# interface atm number.subint multipoint
ATM(config)# lane client ethernet vlan-num elan-num

32. 用show lane server 顯示LES的狀態.

33. 用show lane bus顯示bus的狀態.

34. 用show lane database顯示LECS數據庫可內容.

35. 用show lane client顯示LEC的狀態.

36. 用show module顯示已安裝的模塊列表.

37. 用物理接口建立與VLAN的連接:
router# configure terminal
router(config)# interface media module/port
router(config-if)# description description-string
router(config-if)# ip address ip-addr subnet-mask
router(config-if)# no shutdown

38. 用中繼鏈路來建立與VLAN的連接:
router(config)# interface module/port.subinterface
router(config-ig)# encapsulation[isl|dotlq] vlan-number
router(config-if)# ip address ip-address subnet-mask

39. 用LANE 來建立與VLAN的連接:
router(config)# interface atm module/port
router(config-if)# no ip address
router(config-if)# atm pvc 1 0 5 qsaal
router(config-if)# atm pvc 2 0 16 ilni
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-mask
router(config-if)# lane client ethernet elan-num
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-name
router(config-if)# lane client ethernet elan-name
router(config-if)# …

40. 為了在路由處理器上進行動態路由配置,可以用下列IOS命令來進行:
router(config)# ip routing
router(config)# router ip-routing-protocol
router(config-router)# network ip-network-number
router(config-router)# network ip-network-number

41. 配置默認路由:
switch(enable) set ip route default gateway

42. 為一個路由處理器分配VLANID,可在接口模式下使用下列命令:
router(config)# interface interface number
router(config-if)# mls rp vlan-id vlan-id-num

43. 在路由處理器啟用MLSP:
router(config)# mls rp ip

44. 為了把一個外置的路由處理器接口和交換機安置在同一個VTP域中:
router(config)# interface interface number
router(config-if)# mls rp vtp-domain domain-name

45. 查看指定的VTP域的信息:
router# show mls rp vtp-domain vtp domain name

46. 要確定RSM或路由器上的管理接口,可以在接口模式下輸入下列命令:
router(config-if)#mls rp management-interface

47. 要檢驗MLS-RP的配置情況:
router# show mls rp

48. 檢驗特定接口上的MLS配置:
router# show mls rp interface interface number

49. 為了在MLS-SE上設置流掩碼而又不想在任一個路由處理器接口上設置訪問列表:
set mls flow [destination|destination-source|full]

50. 為使MLS和輸入訪問列表可以兼容,可以在全局模式下使用下列命令:
router(config)# mls rp ip input-acl

51. 當某個交換機的第3層交換失效時,可在交換機的特權模式下輸入下列命令:
switch(enable) set mls enable

52. 若想改變老化時間的值,可在特權模式下輸入以下命令:
switch(enable) set mls agingtime agingtime

53. 設置快速老化:
switch(enable) set mls agingtime fast fastagingtime pkt_threshold

54. 確定那些MLS-RP和MLS-SE參與了MLS,可先顯示交換機引用列表中的內容再確定:
switch(enable) show mls include

55. 顯示MLS高速緩存記錄:
switch(enable) show mls entry

56. 用命令show in arp顯示ARP高速緩存區的內容。

57. 要把路由器配置為HSRP備份組的成員,可以在接口配置模式下使用下面的命令:
router(config-if)# standby group-number ip ip-address

58. 為了使一個路由器重新恢復轉發路由器的角色,在接口配置模式下:
router(config-if)# standy group-number preempt

59. 訪問時間和保持時間參數是可配置的:
router(config-if)# standy group-number timers hellotime holdtime

60. 配置HSRP跟蹤:
router(config-if)# standy group-number track type-number interface-priority

61. 要顯示HSRP路由器的狀態:
router# show standby type-number group brief

62. 用命令show ip igmp確定當選的查詢器。

63. 啟動IP組播路由選擇:
router(config)# ip muticast-routing

64. 啟動接口上的PIM:
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

65. 啟動稀疏-稠密模式下的PIM:
router# ip multicast-routing
router# interface type number
router# ip pim sparse-dense-mode

66. 核實PIM的配置:
dallasr1># show ip pim interface[type number] [count]

67. 顯示PIM鄰居:
dallasr1># show ip neighbor type number

68. 為了配置RP的地址,命令如下:
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

69. 選擇一個默認的RP:
dallasr1># ip pim rp-address
     通告RP和它所服務的組范圍:
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
     為管理范圍組通告RP的地址:
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
     設定一個RP映像代理:
dallasr1># ip pim send-rp-discovery scope ttl
     核實組到RP的映像:
dallasr1># show ip pim rp mapping
dallasr1># show ip pim rp [group-name|group-address] [mapping]

70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value設定TTL閥值:
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

71. 用show ip pim neighbor顯示PIM鄰居表。

72. 顯示組播通信路由表中的各條記錄:
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

73. 要記錄一個路由器接受和發送的全部IP組播包:
dallasr1> #debug ip mpacket [detail] [access-list][group]

74. 要在CISCO路由器上配置CGMP:
dallasr1>(config-if)# ip cgmp

75.配置一個組播路由器,使之加入某一個特定的組播組:
dallasr1>(config-if)# ip igmp join-group group-address

76. 關閉CGMP:
dallasr1>(config-if)# no ip cgmp

77. 啟動交換機上的CGMP:
dallasr1>(enable) set cgmp enable

78. 核實Catalyst交換機上CGMP的配置情況:
catalystla1>(enable) show config
set prompt catalystla1>
set interface sc0 192.168.1.1 255.255.255.0
set cgmp enable

79. CGMP離開的設置:
Dallas_SW(enable) set cgmp leave

80. 在Cisco設備上修改控制端口密碼:
R1(config)# line console 0
R1(config-line)# login
R1(config-line)# password Lisbon
R1(config)# enable password Lilbao
R1(config)# login local
R1(config)# username student password cisco

81. 在Cisco設備上設置控制臺及vty端口的會話超時:
R1(config)# line console 0
R1(config-line)# exec-timeout 5 10
R1(config)# line vty 0 4
R1(config-line)# exec-timeout 5 2

82. 在Cisco設備上設定特權級:
R1(config)# privilege configure level 3 username
R1(config)# privilege configure level 3 copy run start
R1(config)# privilege configure level 3 ping
R1(config)# privilege configure level 3 show run
R1(config)# enable secret level 3 cisco

83. 使用命令privilege 可定義在該特權級下使用的命令:
router(config)# privilege mode level level command

84. 設定用戶特權級:
router(config)# enable secret level 3 dallas
router(config)# enable secret san-fran
router(config)# username student password cisco

85. 標志設置與顯示:
R1(config)# banner motd ‘unauthorized access will be prosecuted!’

86. 設置vty訪問:
R1(config)# access-list 1 permit 192.168.2.5
R1(config)# line vty 0 4
R1(config)# access-class 1 in

87. 配置HTTP訪問:
Router3(config)# access-list 1 permit 192.168.10.7
Router3(config)# ip http sever
Router3(config)# ip http access-class 1
Router3(config)# ip http authentication local
Router3(config)# username student password cisco

88. 要啟用HTTP訪問,請鍵入以下命令:
switch(config)# ip http sever

89. 在基于set命令的交換機上用setCL1啟動和核實端口安全:
switch(enable) set port security mod_num/port_num…enable mac address
switch(enable) show port mod_num/port_num
     在基于CiscoIOS命令的交換機上啟動和核實端口安全:
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
switch# show mac-address-table security [type module/port]

90. 用命令access-list在標準通信量過濾表中創建一條記錄:
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

91. 用命令access-list在擴展通信量過濾表中創建一條記錄:
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

92. 對于帶內路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name in [type number]

93. 對于帶外路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

94. set snmp命令選項:
set snmp community {read-only|ready-write|read-write-all}[community_string]

95. set snmp trap 命令格式如下:
set snmp trap {enable|disable}
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
set snmp trap rvcr_addr rcvr_community

96. 啟用SNMP chassis 陷阱:
Console>(enable) set snmp trap enable chassis

97. 啟用所有SNMP chassis 陷阱:
Console>(enable) set snmp trap enable

98. 禁用SNMP chassis 陷阱:
Console>(enable) set snmp trap disable chassis

99. 給SNMP陷阱接收表加一條記錄:
Console>(enable) set snmp trap 192.122.173.42  public

100. show snmp 輸出結果。

101. 命令set snmp rmon enable 的輸出結果。

102. 顯示SPAN信息:
Consile> show span

上一篇:Win2000常用端口列表
下一篇:CISCO技術--路由協議和路由器的工作原理
評論列表
正在加載評論……
  
評論   
呢  稱:
驗證碼: 若看不清請點擊更換!
內  容:
 
 
  在線洽談咨詢:
點擊這里,在線洽談   點擊這里,在線洽談   點擊這里,在線洽談
與我交談  與我交談 與我交談
乘車路線    匯款方式   加盟合作  人才招聘  
公司地址:青海省西寧市西關大街73號(三二四部隊招行所四樓)     青ICP備13000578號-1 公安機關備案號:63010402000123    
QQ:147399120    mail:[email protected]    電話: 13897410341    郵編:810000
© Copyright( 2008-2009) QhWins.Com All Rights Reserved    版權所有:西寧威勢電子信息服務有限公司 未經書面制授權,請勿隨意轉載!
業務:青海網站制做青海網站建設青海網頁設計西寧網站制做西寧網站建設青海域名注冊青海網絡推廣青海網站推廣青海空間租用青海軟件開發網站安全網絡安全

广西快乐10分官网网 金斧子配资 开盘即涨停意味着什么 湖北11选5胆拖玩法 辉煌棋牌? 排列三投资稳定挣钱方案 11号球衣篮球明星 有没有所以的快乐十分app 钱龙捕鱼个人技巧 如何在手机上看股市的动态 广东36福彩开奖走势图 刘伯温四肖期期中特枓 天津麻将规则 体彩甘肃11选5玩法 网赚app 股票融资比例是多少 河南体彩十一选五开奖结果图